What's New in v19.2.0-rc.3

Warning:
This version of CockroachDB is no longer supported. For more details, see the Release Support Policy.

November 4, 2019

Warning:

A denial-of-service (DoS) vulnerability is present in CockroachDB v19.2.0 - v19.2.11 due to a bug in protobuf. This is resolved in CockroachDB v19.2.12 and later releases. When upgrading is not an option, users should audit their network configuration to verify that the CockroachDB HTTP port is not available to untrusted clients. We recommend blocking the HTTP port behind a firewall.

For more information, including other affected versions, see Technical Advisory 58932.

Get future release notes emailed to you:

Downloads

Docker image

icon/buttons/copy
$ docker pull cockroachdb/cockroach-unstable:v19.2.0-rc.3

General changes

  • Go 1.12.12 is now required to build CockroachDB from source. #41994

SQL language changes

  • Changed the data type of the system.reports_meta.generated and system.replication_constraint_stats.violation_start columns from TIMESTAMP to TIMESTAMPTZ. #41915

Bug fixes

  • Fixed a rare corruption bug when files are ingested that do not overlap with the in-memory buffer and compaction has fallen behind. #42009
  • CockroachDB no longer erroneously transfers leases to replicas that are in the process of being removed, which could lead to ranges being unavailable due to an invalid lease. #42079

Doc updates

Contributors

This release includes 4 merged PRs by 3 authors.

YesYes NoNo